Jump to content

Photoshop Elements 3.0 Help!!


Recommended Posts

For Christmas I got Photoshop Elements 3.0 I installed it and played around with it, it seemed fine.

Today when I try I keep getting a message that says

"There was a problem opening the catalog named "My Catalog"

Another user or application may have the catalog open, or one or more files may be missing, out of date or damaged.

Attempt to compact or recover this catalog, then open again?"

Then you have a choice of OK or CANCEL.

I click OK and it says "recovery sucssesful" but a "open catalog" window comes up and says "look in catalogs" and in the window it has ipod photo cache and My catalogs.psa.

No matter what I do I cant seem to get to the Photoshop menu again. I tried uninstalling and reinstalling and still get the same thing.

Has anyone seen this before? Can someone help me with this.

Thanks to anyone who can help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...